const regex = /geo:-?[0-9]{1,2}\.[0-9]*,-?[0-9]{1,3}\.?[0-9]*(;u=[0-9]{1,2})?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('geo:-?[0-9]{1,2}\\.[0-9]*,-?[0-9]{1,3}\\.?[0-9]*(;u=[0-9]{1,2})?', 'gm')
const str = `geo:37.786971,-122.399677
geo:37.786971,-122.399677;u=35`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}