re = /geo:-?[0-9]{1,2}\.[0-9]*,-?[0-9]{1,3}\.?[0-9]*(;u=[0-9]{1,2})?/m
str = 'geo:37.786971,-122.399677
geo:37.786971,-122.399677;u=35'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end