#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<a.*?\[monitory\].*?href=["'](https?:\/\/.*?)["']>"
Local $sString = "<a [monitory] href=|http:/www.teste.com|>" & @CRLF & _
"<a [monitory] href=|http://www.teste.com|>" & @CRLF & _
"<a [monitory] href="http://www.teste.com">" & @CRLF & _
"<a [monitory] href="http://www.link1.com"><a [monitory] href="http://www.link2.com">"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")