re = /<a.*?\[monitory\].*?href=["'](https?:\/\/.*?)["']>/m
str = '<a [monitory] href=|http:/www.teste.com|>
<a [monitory] href=|http://www.teste.com|>
<a [monitory] href="http://www.teste.com">
<a [monitory] href="http://www.link1.com"><a [monitory] href="http://www.link2.com">'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end