import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<a.*?\\[monitory\\].*?href=[\"'](https?:\\/\\/.*?)[\"']>";
final String string = "<a [monitory] href=|http:/www.teste.com|>\n"
+ "<a [monitory] href=|http://www.teste.com|>\n"
+ "<a [monitory] href=\"http://www.teste.com\">\n"
+ "<a [monitory] href=\"http://www.link1.com\"><a [monitory] href=\"http://www.link2.com\">";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}