import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[A-Z][0-9].[0-9][A-Z].[0-9][A-Z][A-Z][0-9]";
final String string = "A9f8Zi5KH8\n"
+ "Arf8Zi5KH8\n"
+ "A9x8Zi5KH8\n"
+ "A9f8Zi5KMt\n\n\n\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}