$re = '/[A-Z][0-9].[0-9][A-Z].[0-9][A-Z][A-Z][0-9]/';
$str = 'A9f8Zi5KH8
Arf8Zi5KH8
A9x8Zi5KH8
A9f8Zi5KMt
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);