re = /[A-Z][0-9].[0-9][A-Z].[0-9][A-Z][A-Z][0-9]/
str = 'A9f8Zi5KH8
Arf8Zi5KH8
A9x8Zi5KH8
A9f8Zi5KMt
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end