import re
regex = re.compile(r"^\d+\s", flags=re.MULTILINE)
test_str = "0 Ackman, R.G.. Tocher, C.S. and McLachlan. J.. 1968. Marine phytoplankter fatty acids. J. Fish. Res. Board Can., 25: 1603-1620. 1"
subst = "''"
result = regex.sub(subst, test_str)
if result:
print(result)