using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\*(?!\s)(.*?)(?<!\s|\*)\*(?=\s|$)";
string input = @"*foo 1 * 2 bar* foo *b* azz *qu **ux* *1**2.* ****1* *-***1* ****";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}