re = /\*(?!\s)(.*?)(?<!\s|\*)\*(?=\s|$)/m
str = '*foo 1 * 2 bar* foo *b* azz *qu **ux* *1**2.* ****1* *-***1* ****'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end