$re = '/\*(?!\s)(.*?)(?<!\s|\*)\*(?=\s|$)/m';
$str = '*foo 1 * 2 bar* foo *b* azz *qu **ux* *1**2.* ****1* *-***1* ****';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);