package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)\[\[ *fi(?:le|chier) *: *([^\|\]]*)[^\]]*\]\]`)
var str = `{{Infobox xyz
|aaa= Xyz
|bbb= [[Xyz]]
|ccc=[[File:xyz.jpg|thumb|Xyz.]]
|ddd= {{lang|en|xyz}}
}}
[[File:abc.jpg|thumb|Abc.]]`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}