$re = '/\[\[ *fi(?:le|chier) *: *([^\|\]]*)[^\]]*\]\]/mi';
$str = '{{Infobox xyz
|aaa= Xyz
|bbb= [[Xyz]]
|ccc=[[File:xyz.jpg|thumb|Xyz.]]
|ddd= {{lang|en|xyz}}
}}
[[File:abc.jpg|thumb|Abc.]]';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;