#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?<id>[a-zA-Z0-9]{8})\s+(?<conn>\w+=\S+)\s+(?<op>\w+=\S+)\s+(?<cmd>.*?)\s*(?<rest>\w+=.*)?$"
Local $sString = "620da112 conn=2871219 op=1 SRCH attr=extensionAttribute6" & @CRLF & _
"620da112 conn=2871220 fd=60 ACCEPT from IP=10.17.28.159:35708 (IP=0.0.0.0:19000)" & @CRLF & _
"620da112 conn=2871219 op=1 SEARCH RESULT tag=101 err=0 nentries=1 text=" & @CRLF & _
"620da112 conn=2871219 op=2 UNBIND" & @CRLF & _
"620da112 conn=2871219 fd=52 closed" & @CRLF & _
"620da112 conn=2871220 fd=60 TLS established tls_ssf=256 ssf=256" & @CRLF & _
"620da112 conn=2871220 op=0 BIND dn="cn=admin,dc=ClinicalPortal" method=128" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")