import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<id>[a-zA-Z0-9]{8})\\s+(?<conn>\\w+=\\S+)\\s+(?<op>\\w+=\\S+)\\s+(?<cmd>.*?)\\s*(?<rest>\\w+=.*)?$";
final String string = "620da112 conn=2871219 op=1 SRCH attr=extensionAttribute6\n"
+ "620da112 conn=2871220 fd=60 ACCEPT from IP=10.17.28.159:35708 (IP=0.0.0.0:19000)\n"
+ "620da112 conn=2871219 op=1 SEARCH RESULT tag=101 err=0 nentries=1 text=\n"
+ "620da112 conn=2871219 op=2 UNBIND\n"
+ "620da112 conn=2871219 fd=52 closed\n"
+ "620da112 conn=2871220 fd=60 TLS established tls_ssf=256 ssf=256\n"
+ "620da112 conn=2871220 op=0 BIND dn=\"cn=admin,dc=ClinicalPortal\" method=128\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}