# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?<id>[a-zA-Z0-9]{8})\s+(?<conn>\w+=\S+)\s+(?<op>\w+=\S+)\s+(?<cmd>.*?)\s*(?<rest>\w+=.*)?$"
test_str = ("620da112 conn=2871219 op=1 SRCH attr=extensionAttribute6\n"
"620da112 conn=2871220 fd=60 ACCEPT from IP=10.17.28.159:35708 (IP=0.0.0.0:19000)\n"
"620da112 conn=2871219 op=1 SEARCH RESULT tag=101 err=0 nentries=1 text=\n"
"620da112 conn=2871219 op=2 UNBIND\n"
"620da112 conn=2871219 fd=52 closed\n"
"620da112 conn=2871220 fd=60 TLS established tls_ssf=256 ssf=256\n"
"620da112 conn=2871220 op=0 BIND dn=\"cn=admin,dc=ClinicalPortal\" method=128\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.