const regex = /0?(\+?91)? ?[7-9][0-9]{9}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('0?(\\+?91)? ?[7-9][0-9]{9}', 'g')
const str = `+91 7990989898
91 7990989898
091 7990989898
0 7990989898
7990989898
+917990989898
917990989898
07990989898
0917990989898`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}