import re
regex = re.compile(r"0?(\+?91)? ?[7-9][0-9]{9}")
test_str = ("+91 7990989898\n"
"91 7990989898\n"
"091 7990989898\n"
"0 7990989898\n"
"7990989898\n"
"+917990989898\n"
"917990989898\n"
"07990989898\n"
"0917990989898")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")