re = /0?(\+?91)? ?[7-9][0-9]{9}/
str = '+91 7990989898
91 7990989898
091 7990989898
0 7990989898
7990989898
+917990989898
917990989898
07990989898
0917990989898'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end