$re = '/^([\+0-9]{2,5}|0)? ?[1-9][0-9]{2}[ \-]?[0-9]{3}[ \-]?[0-9]{4}$/m';
$str = '+91 7990989898
91 7990989898
091 7990989898
0 7990989898
(0+91)7990989898
+7990989898
0(+91) 7990989898
0(91) 7990989898
7990989898
+917990989898
917990989898
07990989898
0917990989898
(91)7990989898
(+91)7990989898
(91) 7990989898
(+91) 7990989898
(091) 7990989898
(091)7990989898
0+91 7990989898
+1 9898998988
+1 3434343434';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);