import Foundation
let pattern = #"^([\+0-9]{2,5}|0)? ?[1-9][0-9]{2}[ \-]?[0-9]{3}[ \-]?[0-9]{4}$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
+91 7990989898
91 7990989898
091 7990989898
0 7990989898
(0+91)7990989898
+7990989898
0(+91) 7990989898
0(91) 7990989898
7990989898
+917990989898
917990989898
07990989898
0917990989898
(91)7990989898
(+91)7990989898
(91) 7990989898
(+91) 7990989898
(091) 7990989898
(091)7990989898
0+91 7990989898
+1 9898998988
+1 3434343434
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)