// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([\+0-9]{2,5}|0)? ?[1-9][0-9]{2}[ \-]?[0-9]{3}[ \-]?[0-9]{4}$").unwrap();
let string = "+91 7990989898
91 7990989898
091 7990989898
0 7990989898
(0+91)7990989898
+7990989898
0(+91) 7990989898
0(91) 7990989898
7990989898
+917990989898
917990989898
07990989898
0917990989898
(91)7990989898
(+91)7990989898
(91) 7990989898
(+91) 7990989898
(091) 7990989898
(091)7990989898
0+91 7990989898
+1 9898998988
+1 3434343434";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}