import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[<>\\&\\~\\|\\@]";
final String string = "< > & ~ | or @\n"
+ "tes<t\n"
+ "this is magic\n"
+ "Testi|g\n"
+ "m@ster\n"
+ "&\n"
+ "Tese_ting\n"
+ "asdf.asdf\n"
+ "asdf..~.\n"
+ "asdf>?";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}