$re = '/[<>\&\~\|\@]/';
$str = '< > & ~ | or @
tes<t
this is magic
Testi|g
m@ster
&
Tese_ting
asdf.asdf
asdf..~.
asdf>?';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);