using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[(([^][]|\[([^][]|\[[^][]*\])*\])*)\]";
string substitution = @"{\1}";
string input = @"[0,0,0,[12,2],0,0,[12,[1,2,3]],12,0,[12,2,[2]],12,0,12,0,0]";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}