import Foundation
let pattern = #"\[(([^][]|\[([^][]|\[[^][]*\])*\])*)\]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"[0,0,0,[12,2],0,0,[12,[1,2,3]],12,0,[12,2,[2]],12,0,12,0,0]"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"{\1}"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)