package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([^/]*?)(?:\.jpg|_cr.*)$`)
var str = `/path/to/photo/file.jpg
/path/to/photo/file_crXXX.jpg`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}