// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([^/]*?)(?:\.jpg|_cr.*)$").unwrap();
let string = "/path/to/photo/file.jpg
/path/to/photo/file_crXXX.jpg";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}