$re = '/([^/]*?)(?:\.jpg|_cr.*)$/m';
$str = '/path/to/photo/file.jpg
/path/to/photo/file_crXXX.jpg';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);