use strict;
my $str = '555 1212
555-1212
555.1212
5551212
936 555 1212
936-555-1212
936.555.1212
(936) 555-1212
9365551212
1 936 555 1212
1-936-555-1212
1.936.555.1212
1 (936) 555-1212
19365551212
+1 936 555 1212
+1-936-555-1212
+1.936.555.1212
+1 (936) 555 1212
+19365551212
23 4 555 1212
23-4-555-1212
23.4.555.1212
2345551212
+23 4 555 1212
+23-4-555-1212
+23.4.555.1212
+2345551212
+23 936 555 1212
+23-936-555-1212
+23.936.555.1212
+23 (936) 555 1212
+239365551212
+233 936 555 1212
+233-936-555-1212
+233.936.555.1212
+233 (936) 555 1212
+2339365551212';
my $regex = qr/^(?:(?<LEADING_PUNCT>\+?[-. (]*)(?<COUNTRY_CODE>\d{1,3}))?(?<OPT_DELIM_1>[-. )(]*)(?<AREA_CODE>\d{1,3})?(?<OPT_DELIM_2>[-. )(]*)(?<PREFIX>\d{3})(?<OPT_DELIM_3>[-. )(]*)(?<SUFFIX>\d{4})$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}