import re
regex = re.compile(r"^(?:(?<LEADING_PUNCT>\+?[-. (]*)(?<COUNTRY_CODE>\d{1,3}))?(?<OPT_DELIM_1>[-. )(]*)(?<AREA_CODE>\d{1,3})?(?<OPT_DELIM_2>[-. )(]*)(?<PREFIX>\d{3})(?<OPT_DELIM_3>[-. )(]*)(?<SUFFIX>\d{4})$", flags=re.MULTILINE)
test_str = ("555 1212\n"
"555-1212\n"
"555.1212\n"
"5551212\n\n"
"936 555 1212\n"
"936-555-1212\n"
"936.555.1212\n"
"(936) 555-1212\n"
"9365551212\n\n"
"1 936 555 1212\n"
"1-936-555-1212\n"
"1.936.555.1212\n"
"1 (936) 555-1212\n"
"19365551212\n\n"
"+1 936 555 1212\n"
"+1-936-555-1212\n"
"+1.936.555.1212\n"
"+1 (936) 555 1212\n"
"+19365551212\n\n"
"23 4 555 1212\n"
"23-4-555-1212\n"
"23.4.555.1212\n"
"2345551212\n\n"
"+23 4 555 1212\n"
"+23-4-555-1212\n"
"+23.4.555.1212\n"
"+2345551212\n\n"
"+23 936 555 1212\n"
"+23-936-555-1212\n"
"+23.936.555.1212\n"
"+23 (936) 555 1212\n"
"+239365551212\n\n"
"+233 936 555 1212\n"
"+233-936-555-1212\n"
"+233.936.555.1212\n"
"+233 (936) 555 1212\n"
"+2339365551212")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")