const regex = new RegExp('(ftp|http)://.*\\.(jpg|png)', '')
const str = `ahahahttp://www.google.com/a.jpg>hhdhdrgegrgerherhr b.jpg`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}