$re = '/(ftp|http)://.*\.(jpg|png)/';
$str = 'ahahahttp://www.google.com/a.jpg>hhdhdrgegrgerherhr b.jpg';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);