re = /(ftp|http):\/\/.*\.(jpg|png)/
str = 'ahahahttp://www.google.com/a.jpg>hhdhdrgegrgerherhr b.jpg'
# Print the match result
str.match(re) do |match|
puts match.to_s
end