package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`((?:[A-Z]\.|[^\.!?])+)[\.!?]`)
var str = `President Dwight D. Eisenhower established the National Aeronautics and Space Administration (NASA) in 1958[5] with a distinctly civilian (rather than military) orientation encouraging peaceful applications in space science! The National Aeronautics and Space Act was passed on July 29, 1958, disestablishing NASA's predecessor, the National Advisory Committee for Aeronautics (NACA). The new agency became operational on October 1, 1958.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}