use strict;
my $str = 'President Dwight D. Eisenhower established the National Aeronautics and Space Administration (NASA) in 1958[5] with a distinctly civilian (rather than military) orientation encouraging peaceful applications in space science! The National Aeronautics and Space Act was passed on July 29, 1958, disestablishing NASA\'s predecessor, the National Advisory Committee for Aeronautics (NACA). The new agency became operational on October 1, 1958.';
my $regex = qr/((?:[A-Z]\.|[^\.!?])+)[\.!?]/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}