using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(\w{2,})\b.*\b\1\b";
string input = @"ABC foo ABC bar
ABC foo ABCD bar
baz foo bar bar
baz foo barbar";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}