$re = '/\b(\w{2,})\b.*\b\1\b/m';
$str = 'ABC foo ABC bar
ABC foo ABCD bar
baz foo bar bar
baz foo barbar';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);