re = /\b(\w{2,})\b.*\b\1\b/m
str = 'ABC foo ABC bar
ABC foo ABCD bar
baz foo bar bar
baz foo barbar'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end