import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\p{Alpha}\\p{Alnum}*(?:-\\p{Alnum}+)*$";
final String string = "a12bc-foo12-111-aaa\n"
+ "a12bc-foo12--111-aaa\n"
+ "a12bc\n"
+ "1a12bc\n"
+ "ab----1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}