// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\p{Alpha}\p{Alnum}*(?:-\p{Alnum}+)*$").unwrap();
let string = "a12bc-foo12-111-aaa
a12bc-foo12--111-aaa
a12bc
1a12bc
ab----1";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}