$re = '/^\p{Alpha}\p{Alnum}*(?:-\p{Alnum}+)*$/m';
$str = 'a12bc-foo12-111-aaa
a12bc-foo12--111-aaa
a12bc
1a12bc
ab----1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);