using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\$?\s*(\d{1,3}(,\d{3})+|\d+)(\.(\d\d))?";
string input = @"about 423,348,442.55
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}