package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\$?\s*(\d{1,3}(,\d{3})+|\d+)(\.(\d\d))?`)
var str = `about 423,348,442.55
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}