$re = '/\$?\s*(\d{1,3}(,\d{3})+|\d+)(\.(\d\d))?/';
$str = 'about 423,348,442.55
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);