using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=::)([^<]+)\s+.*?(<.*)>";
string input = @"<Object::1 <1,2><3,4><3,3>>
<Object::string <1,2><3,4>>
<Object::3 <1,2> 5>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}