$re = '/(?<=::)([^<]+)\s+.*?(<.*)>/m';
$str = '<Object::1 <1,2><3,4><3,3>>
<Object::string <1,2><3,4>>
<Object::3 <1,2> 5>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);