import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=::)([^<]+)\\s+.*?(<.*)>";
final String string = "<Object::1 <1,2><3,4><3,3>> \n"
+ "<Object::string <1,2><3,4>>\n"
+ "<Object::3 <1,2> 5>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}