#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mu)(?:https?:(?:\\?\/\\?\/|www\.)|www\.)[^\s<>"']*\.mp3"
Local $sString = "<div class="wp-playlist wp-audio-playlist wp-playlist-light">" & @CRLF & _
"" & @CRLF & _
"<div class="wp-playlist-current-item"></div>" & @CRLF & _
"" & @CRLF & _
"<p> <audio controls="controls" preload="none" width="" & @CRLF & _
" 1118 "" & @CRLF & _
" >" & @CRLF & _
"</audio></p>" & @CRLF & _
"<div class="wp-playlist-next"></div>" & @CRLF & _
"<div class="wp-playlist-prev">" & @CRLF & _
"</div>" & @CRLF & _
"<p> <noscript></p>" & @CRLF & _
"<ol>" & @CRLF & _
"<li>" & @CRLF & _
"<a href='https://www.caferilik.com/wp-content/uploads/2020/11/Anne-Baba-Biz-Suçluyuz-Muhafazakar-Ailelerde-Kuşak-Çatışması-Sesli-Kitap-www.caferilik.com_.mp3'>" & @CRLF & _
"Anne Baba Biz Suçluyuz - Muhafazakar Ailelerde Kuşak Çatışması (Sesli Kitap) www.caferilik.com<" & @CRLF & _
"/a></li>" & @CRLF & _
"</ol>" & @CRLF & _
"<p> </noscript><br />" & @CRLF & _
" " & @CRLF & _
"<script type="application/json" class="wp-playlist-script">" & @CRLF & _
"{"type":"audio","tracklist":true,"tracknumbers":true,"images":true,"artists":true," & @CRLF & _
""tracks":[{"src":"https:\/\/www.caferilik.com\/wp-content\/uploads\/2020\/11\/Anne-Baba-Biz-Su\u00e7luyuz-Muhafazakar-Ailelerde-Ku\u015fak-\u00c7at\u0131\u015fmas\u0131-Sesli-Kitap-www.caferilik.com_.mp3"," & @CRLF & _
""type":"audio\/mpeg","title":"Anne Baba Biz Su\u00e7luyuz - Muhafazakar Ailelerde Ku\u015fak \u00c7at\u0131\u015fmas\u0131 (Sesli Kitap) www.caferilik.com","caption":""," & @CRLF & _
""description":"\"Anne Baba Biz Su\u00e7luyuz - Muhafazakar Ailelerde Ku\u015fak \u00c7at\u0131\u015fmas\u0131 (Sesli Kitap) www.caferilik.com\".","meta":{"length_formatted":"2:28:02"}," & @CRLF & _
""image":{"src":"https:\/\/www.caferilik.com\/wp-includes\/images\/media\/audio.png","width":48,"height":64},"thumb":" & @CRLF & _
"{"src":"https:\/\/www.caferilik.com\/wp-includes\/images\/media\/audio.png","width":48,"height":64}}]}</script>" & @CRLF & _
"</div>" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")